diff setup.py @ 0:21ec6325ae0e

initial import of CAPTCHA middleware; unfinished
author k0s <k0scist@gmail.com>
date Sun, 24 Jan 2010 23:15:57 -0500
parents
children c861518b2a44
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Sun Jan 24 23:15:57 2010 -0500
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = "0.1"
+
+setup(name='CAPTCHAmiddleware',
+      version=version,
+      description="put CAPTCHAs on forms",
+      long_description="""
+""",
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org',
+      license="GPL",
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+         'lxmlmiddleware',
+         'skimpygimpy'
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [paste.app_factory]
+      example-captcha = captchamiddleware.example:factory
+      """,
+      )
+