diff setup.py @ 0:bdc039cb1f2e

wth
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 24 Sep 2013 13:13:35 -0700
parents
children 4cb3971d9d9d
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Sep 24 13:13:35 2013 -0700
@@ -0,0 +1,44 @@
+"""
+setup packaging script for CommitWatcher
+"""
+
+import os
+
+version = "0.0"
+dependencies = ['webob']
+
+# allow use of setuptools/distribute or distutils
+kw = {}
+try:
+    from setuptools import setup
+    kw['entry_points'] = """
+      [console_scripts]
+      CommitWatcher = commitwatcher.main:main
+"""
+    kw['install_requires'] = dependencies
+except ImportError:
+    from distutils.core import setup
+    kw['requires'] = dependencies
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = ''
+
+
+setup(name='CommitWatcher',
+      version=version,
+      description="new service to monitor mozbase commits",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='https://bugzilla.mozilla.org/show_bug.cgi?id=895522',
+      license='MPL2',
+      packages=['commitwatcher'],
+      include_package_data=True,
+      zip_safe=False,
+      **kw
+      )
+