diff setup.py @ 0:9869cf47fcf8 default tip

initial commit of Firefox addon template
author k0s <k0scist@gmail.com>
date Sun, 28 Mar 2010 16:25:58 -0400
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Sun Mar 28 16:25:58 2010 -0400
@@ -0,0 +1,22 @@
+from setuptools import find_packages, setup
+
+version='0.0'
+
+setup(name='FirefoxAddon',
+      version=version,
+      description="template for a firefox addon",
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='',
+      keywords='trac plugin',
+      license="",
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests*']),
+      include_package_data=True,
+      install_requires = [ 'PasteScript' ],
+      zip_safe=False,
+      entry_points = """
+      [paste.paster_create_template]
+      firefoxaddon = firefoxaddon:FirefoxAddon
+      """,
+      )
+