diff setup.py @ 0:67cfeffa0d90

stub from template
author Jeff Hammel <jhammel@mozilla.com>
date Sun, 07 Apr 2013 03:07:39 -0700
parents
children b8be785f8e87
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Sun Apr 07 03:07:39 2013 -0700
@@ -0,0 +1,45 @@
+"""
+setup packaging script for IntentMadeManifest
+"""
+
+import os
+
+version = "0.0"
+dependencies = ['MakeItSo', 'webob']
+
+# allow use of setuptools/distribute or distutils
+kw = {}
+try:
+    from setuptools import setup
+    kw['entry_points'] = """
+      [console_scripts]
+      IntentMadeManifest = IntentMadeManifest.main:main
+      IntentMadeManifest-template = IntentMadeManifest.template:main
+"""
+    kw['install_requires'] = dependencies
+except ImportError:
+    from distutils.core import setup
+    kw['requires'] = dependencies
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = ''
+
+
+setup(name='IntentMadeManifest',
+      version=version,
+      description="python workflow engine via directed graph",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='',
+      license='',
+      packages=['intentmademanifest'],
+      include_package_data=True,
+      zip_safe=False,
+      **kw
+      )
+