diff setup.py @ 246:1c6807a22cea

go tox
author Jeff Hammel <k0scist@gmail.com>
date Fri, 31 Mar 2017 17:53:26 -0700
parents ba7dd9820181
children 43db853df1f8
line wrap: on
line diff
--- a/setup.py	Mon Feb 20 10:13:32 2017 -0800
+++ b/setup.py	Fri Mar 31 17:53:26 2017 -0700
@@ -9,7 +9,6 @@
 
 import os
 from setuptools import setup
-join = os.path.join
 
 try:
     here = os.path.dirname(os.path.abspath(__file__))
@@ -32,15 +31,15 @@
       packages=['makeitso'],
       include_package_data=True,
       package_data={'makeitso': [
-            join('python_package', 'tests', '*')
-#            'python_package/*'
-]},
+            os.path.join('python_package', 'tests', '*')
+      ]},
       zip_safe=False,
       install_requires=[
           # -*- Extra requirements: -*-
           'tempita >= 0.5.1',
           'webob',
       ],
+      tests_require=['tox'],
       entry_points="""
       # -*- Entry points: -*-
       [console_scripts]