diff makeitso/python_module/setup.py @ 129:57834c2b0937

add a single-file module to the thingy
author Jeff Hammel <jhammel@mozilla.com>
date Fri, 08 Jul 2011 10:43:48 -0700
parents
children ee29d37198a3
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/makeitso/python_module/setup.py	Fri Jul 08 10:43:48 2011 -0700
@@ -0,0 +1,34 @@
+import os
+from setuptools import setup
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = None
+
+version = '0.0'
+
+deps = []
+
+setup(name='{{module}}',
+      version=version,
+      description="{{description}}",
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='mozilla',
+      author='{{author}}',
+      author_email='{{email}}',
+      url='{{url}}',
+      license='',
+      py_modules=['{{module}}'],
+      packages=[],
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=deps,
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      {{module}} = {{module}}:main
+      """,
+      )