diff setup.py @ 0:7a76836b50a7

initial (non-working) commit to makeitso
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 02 Nov 2010 17:56:14 -0700
parents
children f064be514e53
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Nov 02 17:56:14 2010 -0700
@@ -0,0 +1,29 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.0'
+
+setup(name='MakeItSo',
+      version=version,
+      description='filesystem template interpreter',
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/',
+      license='',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+        'tempita'
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      makeitso = makeitso.main:main
+      """,
+      )