diff makeitso/python_package/setup.py @ 102:ad5fd3eb6674

template fixes....not the best, but will do
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 11 Jan 2011 16:30:52 -0800
parents 0300ed78d630
children 697568ba4a22
line wrap: on
line diff
--- a/makeitso/python_package/setup.py	Tue Jan 11 14:23:17 2011 -0800
+++ b/makeitso/python_package/setup.py	Tue Jan 11 16:30:52 2011 -0800
@@ -1,7 +1,9 @@
+import os
 from setuptools import setup, find_packages
 
 try:
-    description = file('README.txt').read()
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
 except IOError: 
     description = ''
 
@@ -15,7 +17,7 @@
       author='{{author}}',
       author_email='{{email}}',
       url='{{url}}',
-      license='{{license}}'
+      license='',
       packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
       include_package_data=True,
       zip_safe=False,