diff setup.py @ 102:ad5fd3eb6674

template fixes....not the best, but will do
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 11 Jan 2011 16:30:52 -0800
parents 363f6625d036
children 67b50417b8d1
line wrap: on
line diff
--- a/setup.py	Tue Jan 11 14:23:17 2011 -0800
+++ b/setup.py	Tue Jan 11 16:30:52 2011 -0800
@@ -1,12 +1,18 @@
+import os
 from setuptools import setup, find_packages
 
-version = '0.0'
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = ''
+
+version = '0.1'
 
 setup(name='MakeItSo',
       version=version,
       description='filesystem template interpreter',
-      long_description="""\
-""",
+      long_description=description,
       classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
       keywords='',
       author='Jeff Hammel',
@@ -25,5 +31,6 @@
       # -*- Entry points: -*-
       [console_scripts]
       makeitso = makeitso.makeitso:main
+      make-python-package = makeitso.python:main
       """,
       )