diff setup.py @ 0:6670fe246450

initial commit
author Jeff Hammel <k0scist@gmail.com>
date Thu, 14 Jul 2016 12:27:21 -0700
parents
children dd3f3918cb88
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Thu Jul 14 12:27:21 2016 -0700
@@ -0,0 +1,35 @@
+import os
+from setuptools import setup
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = None
+
+version = '0.0'
+
+deps = []
+
+setup(name='a8e',
+      version=version,
+      description="a8e is `a8e abbreviate`",
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='',
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org/hg/a8e',
+      license='',
+      py_modules=['a8e'],
+      packages=[],
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=deps,
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      a8e = a8e:main
+      """,
+      )
+