diff setup.py @ 0:8e14b6322cc7

initial stub for ateam buildbot
author Jeff Hammel <jhammel@mozilla.com>
date Wed, 22 Dec 2010 11:15:45 -0800
parents
children d7c4e9d6d9dd
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Wed Dec 22 11:15:45 2010 -0800
@@ -0,0 +1,29 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.0'
+
+setup(name='autobot',
+      version=version,
+      description="buildbot incarnation for Mozilla AutoTools team",
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='buildbot automation',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='https://wiki.mozilla.org/Auto-tools',
+      license='MPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+        'buildbot',
+        'buildbot-slave',
+        'virtualenv'
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      """,
+      )