diff setup.py @ 0:284621b3effd

initial commit of bitsyauth, initially from bitsyblog
author k0s <k0scist@gmail.com>
date Mon, 02 Nov 2009 21:37:40 -0500
parents
children ec3c0343a8b5
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Nov 02 21:37:40 2009 -0500
@@ -0,0 +1,31 @@
+from setuptools import setup, find_packages
+
+version = '0.0'
+
+setup(name='bitsyauth',
+      version=version,
+      description="form + digest auth middleware",
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='auth',
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org/hg/bitsyauth',
+      license='GPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=['Paste',
+                        'PasteScript',
+                        'markup',
+                        'skimpgimpy',
+                        ],
+      dependency_links=['https://svn.openplans.org/svn/standalone/markup#egg=markup',
+                        'http://svn.pythonpaste.org/Paste/trunk#egg=Paste',
+                        ],
+      entry_points="""
+      # -*- Entry points: -*-
+              
+      """,
+      )