diff setup.py @ 0:9661071dac87

initial commit of the buttercup flower; just a stub
author k0s <k0scist@gmail.com>
date Fri, 26 Feb 2010 15:53:51 +0000
parents
children f207357d7ca9 1fa9ca23d696
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Fri Feb 26 15:53:51 2010 +0000
@@ -0,0 +1,22 @@
+from setuptools import find_packages, setup
+
+version='0.0'
+
+setup(name='buttercup',
+      version=version,
+      description="paste template for creating instances of the buttercup flower website pattern",
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org',
+      keywords='trac plugin',
+      license="",
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests*']),
+      include_package_data=True,
+      install_requires = [ 'PasteScript' ],
+      zip_safe=False,
+      entry_points = """
+      [paste.paster_create_template]
+      buttercup = buttercup:buttercup
+      """,
+      )
+