diff setup.py @ 22:3b7f4104cd72

add README + release
author Jeff Hammel <jhammel@mozilla.com>
date Thu, 09 Dec 2010 15:33:27 -0800
parents 797e0022d0fa
children 2eaf17cb07f6
line wrap: on
line diff
--- a/setup.py	Thu Dec 09 15:25:00 2010 -0800
+++ b/setup.py	Thu Dec 09 15:33:27 2010 -0800
@@ -3,22 +3,29 @@
 
 version = '0.1'
 
+readme = os.path.join(os.path.dirname(os.path.abspath(__file__)), 'README.txt')
+
+if os.path.exists(readme):
+  description = file(readme).read()
+else:
+  description = ''
+
 setup(name='bzconsole',
       version=version,
       description='console API to bugzilla',
-      long_description="""\
-""",
+      long_description=description,
       classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
       keywords='',
       author='Jeff Hammel',
       author_email='jhammel@mozilla.com',
-      url='http://k0s.org/mozilla/',
-      license='',
+      url='http://k0s.org/mozilla/hg/bzconsole',
+      license='MPL',
       packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
       include_package_data=True,
       zip_safe=False,
       install_requires=[
           # -*- Extra requirements: -*-
+        'simplejson'
       ],
       entry_points="""
       # -*- Entry points: -*-