diff tests/packageA/setup.py @ 6:29b36a390857

add some bogus packages ill need for da test
author Jeff Hammel <jhammel@mozilla.com>
date Fri, 08 Jul 2011 10:52:53 -0700
parents
children e6a62ba0c24d
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/tests/packageA/setup.py	Fri Jul 08 10:52:53 2011 -0700
@@ -0,0 +1,35 @@
+import os
+from setuptools import setup
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = None
+
+version = '0.0'
+
+deps = []
+
+setup(name='packageA',
+      version=version,
+      description="packageA",
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='mozilla',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='example.com',
+      license='',
+      py_modules=['packageA'],
+      packages=[],
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=deps,
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      packageA = packageA:main
+      """,
+      )
+