diff setup.py @ 16:c91abbdc871b

* add TODO: dependencies * take docstring from the module itself
author Jeff Hammel <jhammel@mozilla.com>
date Fri, 08 Jul 2011 15:55:00 -0700
parents dba783d48eae
children dabf5e1bdf92
line wrap: on
line diff
--- a/setup.py	Fri Jul 08 15:35:53 2011 -0700
+++ b/setup.py	Fri Jul 08 15:55:00 2011 -0700
@@ -1,10 +1,9 @@
-import os
 from setuptools import setup
 
 try:
-    here = os.path.dirname(os.path.abspath(__file__))
-    description = file(os.path.join(here, 'README.txt')).read()
-except IOError:
+    import carton
+    description = carton.__doc__
+except ImportError:
     description = None
 
 version = '0.1'