diff setup.py @ 0:0a54e5bd2875

initial import of cropresive from https://svn.openplans.org/svn/standalone/cropresize
author k0s <k0scist@gmail.com>
date Thu, 29 Oct 2009 18:28:13 -0400
parents
children 0a2302b6377b
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Thu Oct 29 18:28:13 2009 -0400
@@ -0,0 +1,32 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.1.1'
+
+setup(name='cropresize',
+      version=version,
+      description="crop and resize an image without doing the math yourself",
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='image',
+      author='Jeff Hammel',
+      author_email='jhammel@openplans.org',
+      url='http://pypi.python.org/pypi/cropresize',
+      license='GPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+        'PIL',
+        ],
+      dependency_links=[
+        "http://dist.repoze.org/PIL-1.1.6.tar.gz",
+        ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      crop-resize = cropresize:main
+      """,
+      )