diff setup.py @ 3:2be0070c6f95

path-independent way of getting the description
author k0s <k0scist@gmail.com>
date Sat, 06 Mar 2010 13:11:46 -0500
parents 0676435d1186
children c89738f3f417
line wrap: on
line diff
--- a/setup.py	Fri Mar 05 16:46:05 2010 -0500
+++ b/setup.py	Sat Mar 06 13:11:46 2010 -0500
@@ -2,7 +2,8 @@
 import sys, os
 
 try:
-    description = file('README.txt').read()
+    filename = os.path.join(os.path.dirname(__file__), 'README.txt')
+    description = file(filename).read()
 except:
     description = ''