diff setup.py @ 0:fa2005f769eb

adding decoupage from http://my-svn.assembla.com/svn/arbez/decoupage r355
author k0s <k0scist@gmail.com>
date Mon, 07 Sep 2009 13:40:22 -0400
parents
children 041958c8c8f2
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Sep 07 13:40:22 2009 -0400
@@ -0,0 +1,46 @@
+from setuptools import setup, find_packages
+import sys, os
+
+try:
+    description = file("README.txt").read()
+except IOError:
+    description = ''
+
+version = '0.1.4'
+
+setup(name='decoupage',
+      version=version,
+      description="Decoupage is the art of decorating an object by gluing colored paper cutouts onto it in combination with special paint effects ...",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://explosivedecompression.net',
+      license="",
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+         'WebOb',	
+         'Paste',
+         'PasteScript',
+         'genshi',
+         'martINI',
+         ],
+      find_links=[
+        'https://svn.openplans.org/svn/standalone/martINI#egg=martINI',
+        ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [paste.app_factory]
+      main = decoupage.factory:factory
+
+      [decoupage.formatters]
+      ignore = decoupage.formatters:Ignore
+      all = decoupage.formatters:All
+      describe = decoupage.formatters:FilenameDescription
+      title = decoupage.formatters:TitleDescription
+      """,
+      )
+