diff setup.py @ 0:bbcc528508f1

initial stub for emaildispatcher framework; ultimately, this should be written in lamson but dont have the patience to learn it today
author k0s <k0scist@gmail.com>
date Wed, 30 Dec 2009 22:46:56 -0500
parents
children 2c76525ce80b
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Wed Dec 30 22:46:56 2009 -0500
@@ -0,0 +1,31 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.0'
+
+setup(name='emaildispatcher',
+      version=version,
+      description='dispatches email to handlers',
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='',
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org',
+      license='',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      emaildispatcher = emaildispatcher.main:main
+
+      [email.dispatchers]
+      extract_images = emaildispatcher.dispatchers:Images
+      """,
+      )