diff setup.py @ 0:3497a30190d2

initial commit of fetch, WIP
author Jeff Hammel <jhammel@mozilla.com>
date Sun, 18 Sep 2011 10:33:04 -0700
parents
children 44cbfaefa85c
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Sun Sep 18 10:33:04 2011 -0700
@@ -0,0 +1,35 @@
+import os
+from setuptools import setup, find_packages
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError: 
+    description = ''
+
+version = "0.0"
+
+dependencies = ['MakeItSo', 'webob']
+
+setup(name='fetch',
+      version=version,
+      description="fetch stuff from the interwebs",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/mozilla/fetch',
+      license='MPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=dependencies,
+      entry_points="""
+      # -*- Entry points: -*-
+
+      [console_scripts]
+      fetch = fetch.main:main
+      """,
+      )
+      
+