diff setup.py @ 0:b5671297a0db

initial commit of hq
author Jeff Hammel <jhammel@mozilla.com>
date Fri, 30 Apr 2010 14:31:35 -0700
parents
children 6c4f258fae85
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Fri Apr 30 14:31:35 2010 -0700
@@ -0,0 +1,28 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.0'
+
+setup(name='hq',
+      version=version,
+      description='mercurial queue extension front-end policy manager',
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='hg mercurial patch',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org',
+      license='MPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      hq = hq.main:main
+      """,
+      )