diff setup.py @ 0:3c3522ce6e3a

initial import of martINI from https://svn.openplans.org/svn/standalone/martINI/
author k0s <k0scist@gmail.com>
date Tue, 08 Dec 2009 15:13:28 -0500
parents
children 5627074cd79b
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Dec 08 15:13:28 2009 -0500
@@ -0,0 +1,37 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.2.3'
+
+setup(name='martINI',
+      version=version,
+      description="edit .ini files from the command line",
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='ini cli',
+      author='Jeff Hammel',
+      author_email='jhammel@openplans.org',
+      url='http://k0s.org',
+      license='GPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+         'WebOb',	
+         'Paste',
+         'PasteScript',
+         'genshi'
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      ini-get = martini.main:get
+      ini-set = martini.main:set
+      ini-delete = martini.main:delete
+
+      [paste.app_factory]
+      main = martini.web:factory
+      """,
+      )