diff setup.py @ 0:d28351df9a8a

initial commit from http://k0s.org/hg/config/file/tip/python/example/process.py
author Jeff Hammel <k0scist@gmail.com>
date Wed, 30 Nov 2016 12:40:25 -0800
parents
children a1b13d024582
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Wed Nov 30 12:40:25 2016 -0800
@@ -0,0 +1,45 @@
+"""
+setup packaging script for periprocess
+"""
+
+import os
+
+version = "0.0"
+dependencies = []
+
+# allow use of setuptools/distribute or distutils
+kw = {}
+try:
+    from setuptools import setup
+    kw['entry_points'] = """
+      [console_scripts]
+      periprocess = periprocess.main:main
+      periprocess-template = periprocess.template:main
+"""
+    kw['install_requires'] = dependencies
+except ImportError:
+    from distutils.core import setup
+    kw['requires'] = dependencies
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = ''
+
+
+setup(name='periprocess',
+      version=version,
+      description="subprocess front-end that keeps buffers of stdout/stderr",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org/hg/periprocess',
+      license='MPL',
+      packages=['periprocess'],
+      include_package_data=True,
+      zip_safe=False,
+      **kw
+      )
+