diff setup.py @ 0:6fa6d987b3af

initial commit of pyloader
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 03 May 2011 08:06:48 -0700
parents
children 47d9472e7754
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue May 03 08:06:48 2011 -0700
@@ -0,0 +1,31 @@
+import os
+from setuptools import setup, find_packages
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError: 
+    description = ''
+
+version = "0.1"
+dependencies = []
+
+setup(name='pyloader',
+      version=version,
+      description="Load python attributes from a string",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/',
+      license='MPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=dependencies,
+      entry_points="""
+      # -*- Entry points: -*-
+      """,
+      )
+      
+