diff setup.py @ 1:55578cf505dd

add some documentation for redirector
author Jeff Hammel <k0scist@gmail.com>
date Wed, 10 Mar 2010 10:45:11 -0500
parents af82aaec0377
children ff524f0a62de
line wrap: on
line diff
--- a/setup.py	Mon Sep 07 15:15:48 2009 -0400
+++ b/setup.py	Wed Mar 10 10:45:11 2010 -0500
@@ -1,18 +1,24 @@
 from setuptools import setup, find_packages
 import sys, os
 
-version = "0.1"
+# get the description from the README
+try:
+    filename = os.path.join(os.path.dirname(__file__), 'README.txt')
+    description = file(filename).read()
+except:
+    description = ''
+
+version = "0.1.1"
 
 setup(name='redirector',
       version=version,
       description="WSGI middleware/app for managing redirects",
-      long_description="""
-""",
+      long_description=description,
       classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
       author='Jeff Hammel',
-      author_email='jhammel@openplans.org',
-      url='http://k0s.org',
-      license="",
+      author_email='k0scist@gmail.com',
+      url='http://k0s.org/hg/redirector',
+      license="GPL",
       packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
       include_package_data=True,
       zip_safe=False,