diff setup.py @ 0:af10f7e072ed

initial import of stampit
author Jeff Hammel <jhammel@mozilla.com>
date Mon, 19 Apr 2010 17:41:06 -0400
parents
children 3f9fac577d75
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Apr 19 17:41:06 2010 -0400
@@ -0,0 +1,28 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.0'
+
+setup(name='stampit',
+      version=version,
+      description='stamp out virtualenv tarballs appropriate to a platform (and upload them?)',
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='',
+      license='MPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      stampit = stampit.main:main
+      """,
+      )