diff setup.py @ 0:7a60bacc6a22

initial commit
author Jeff Hammel <jhammel@mozilla.com>
date Mon, 27 Dec 2010 22:09:09 -0800
parents
children fc09a7ffb767
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Dec 27 22:09:09 2010 -0800
@@ -0,0 +1,35 @@
+from setuptools import setup, find_packages
+import sys, os
+
+try:
+    description = file('README.txt').read()
+except IOError: 
+    description = ''
+
+version = "0.0"
+
+setup(name='svgsitemap',
+      version=version,
+      description="",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='',
+      author_email='',
+      url='',
+      license="",
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+         'WebOb',	
+         'Paste',
+         'PasteScript',
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [paste.app_factory]
+      main = svgsitemap.factory:factory
+      """,
+      )
+