diff setup.py @ 21:f7396d92446d

bump version
author Jeff Hammel <k0scist@gmail.com>
date Sun, 02 Jun 2024 15:50:28 -0700
parents c6800e0b01ed
children 17e3a9b6b4e2
line wrap: on
line diff
--- a/setup.py	Sun Jun 02 15:47:40 2024 -0700
+++ b/setup.py	Sun Jun 02 15:50:28 2024 -0700
@@ -1,11 +1,17 @@
 from setuptools import setup
 
-try:
-    description = open('README.txt').read()
-except IOError:
-    description = ''
+description = "a place to list links + tools",
 
-version = "0.4.1"
+# :( `twine check` does not like the README
+# because restructured text changed their tbale format
+# https://sublime-and-sphinx-guide.readthedocs.io/en/latest/tables.html
+#try:
+#    description = open('README.txt').read()
+#except IOError:
+#    description = ''
+long_description = description
+
+version = "0.4.2"
 
 # dependencies
 dependencies = [
@@ -23,8 +29,8 @@
 
 setup(name='toolk0s',
       version=version,
-      description="a place to list links + tools",
-      long_description=description,
+      description=description,
+      long_description=long_description,
       classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
       author='Jeff Hammel',
       author_email='k0scist@gmail.com',