diff setup.py @ 9:064e936c7257

pytest integration
author Jeff Hammel <k0scist@gmail.com>
date Fri, 01 Sep 2017 09:29:35 -0700
parents bb8b6b06ca83
children d945a862617c
line wrap: on
line diff
--- a/setup.py	Thu Aug 31 10:06:20 2017 -0700
+++ b/setup.py	Fri Sep 01 09:29:35 2017 -0700
@@ -5,7 +5,8 @@
 import os
 
 version = "0.0"
-dependencies = ['numpy']
+dependencies = ['numerics',
+                'numpy']
 
 # allow use of setuptools/distribute or distutils
 kw = {}
@@ -39,8 +40,8 @@
       license='',
       packages=['tvii'],
       include_package_data=True,
-      tests_require=['tox'],
+      setup_requires=['pytest-runner'],
+      tests_require=['tox', 'pytest'],
       zip_safe=False,
       **kw
       )
-