diff setup.py @ 40:a7d8583f7482

[packaging] lets try out scikit learn
author Jeff Hammel <k0scist@gmail.com>
date Mon, 04 Sep 2017 14:30:56 -0700
parents d945a862617c
children 36c141f0f0bd
line wrap: on
line diff
--- a/setup.py	Mon Sep 04 14:16:29 2017 -0700
+++ b/setup.py	Mon Sep 04 14:30:56 2017 -0700
@@ -10,6 +10,7 @@
                 'numerics',
                 'numpy',
                 'Pillow',
+                'scikit-learn',
                 'scipy']
 
 # allow use of setuptools/distribute or distutils
@@ -17,15 +18,14 @@
 try:
     from setuptools import setup
     kw['entry_points'] = """
-      [console_scripts]
-      tvii = tvii.main:main
-      tvii-template = tvii.template:main
+    [console_scripts]
 """
     kw['install_requires'] = dependencies
 except ImportError:
     from distutils.core import setup
     kw['requires'] = dependencies
 
+
 try:
     here = os.path.dirname(os.path.abspath(__file__))
     description = open(os.path.join(here, 'README.txt')).read()