diff setup.py @ 1:12ac99c240ca default tip

* add documentation * add 1..10 autostep feature * bump version
author Jeff Hammel <k0scist@gmail.com>
date Wed, 10 Mar 2010 17:48:11 -0500
parents 1eea6356d2e5
children
line wrap: on
line diff
--- a/setup.py	Mon Sep 07 15:09:03 2009 -0400
+++ b/setup.py	Wed Mar 10 17:48:11 2010 -0500
@@ -1,12 +1,19 @@
 from setuptools import setup, find_packages
+import os
 
-version = "0.1"
+# get the description from the README
+try:
+    filename = os.path.join(os.path.dirname(__file__), 'README.txt')
+    description = file(filename).read()
+except:
+    description = ''
+
+version = "0.1.1"
 
 setup(name='webcalc',
       version=version,
       description="web-based calculator",
-      long_description="""
-""",
+      long_description=description,
       classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
       author='Jeff Hammel',
       author_email='k0scist@gmail.com',