diff setup.py @ 5:0c2b1fe8f53f

update documentation a little
author k0s <k0scist@gmail.com>
date Sun, 14 Feb 2010 13:25:01 -0500
parents 28c7009bc463
children c576f5877459
line wrap: on
line diff
--- a/setup.py	Fri Feb 12 12:39:14 2010 -0500
+++ b/setup.py	Sun Feb 14 13:25:01 2010 -0500
@@ -1,15 +1,18 @@
+import os
 from setuptools import setup, find_packages
 
-version = "0.1"
+try:
+    filename = os.path.join(os.path.dirname(__file__), 'README.txt')
+    description = file(filename).read()
+except:
+    description = ""
+
+version = "0.1.1"
 
 setup(name='wordstream',
       version=version,
       description="word streamer; conversational and dissociatively play with text with a command line and web interface",
-      long_description="""
-for a demo, see http://k0s.org/wordstream and http://k0s.org/dissociate
-
-Additional documentation forthcoming, until the, the docs == the source
-""",
+      long_description=description,
       classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
       author='Jeff Hammel',
       author_email='k0scist@gmail.com',