diff setup.py @ 0:ec815b7cb142

initial commit of wsgintegrate
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 07 Jun 2011 08:03:09 -0700
parents
children 2b44d878d46f
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Jun 07 08:03:09 2011 -0700
@@ -0,0 +1,36 @@
+from setuptools import setup, find_packages
+import os
+
+version = '0.1.1'
+
+# description
+try:
+  filename = os.path.join(os.path.dirname(__file__), 'README.txt')
+  description = file(filename).read()
+except:
+  description = ''
+
+# dependencies
+dependencies = ['webob']
+try:
+  import json
+except ImportError:
+  dependencies.append('simplejson')
+
+setup(name='wsgintegrate',
+      version=version,
+      description='WSGI integration layer',
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/',
+      license='GPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=dependencies,
+      entry_points="""
+      """,
+      )