diff setup.py @ 0:665b2ae2ecc6

stub project for DocumentIt
author Jeff Hammel <jhammel@mozilla.com>
date Mon, 01 Aug 2011 12:00:51 -0700
parents
children 2a0f13707ccb
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon Aug 01 12:00:51 2011 -0700
@@ -0,0 +1,35 @@
+import os
+from setuptools import setup
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = None
+
+version = '0.0'
+
+deps = []
+
+setup(name='document_it',
+      version=version,
+      description="mirror text documentation to MDN",
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='mozilla',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/mozilla/hg/DocumentIt',
+      license='MPL',
+      py_modules=['document_it'],
+      packages=[],
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=deps,
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      document_it = document_it:main
+      """,
+      )
+