diff setup.py @ 0:1855ba0b873a

initial commit
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 22 Jan 2013 21:30:20 -0800
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Jan 22 21:30:20 2013 -0800
@@ -0,0 +1,45 @@
+"""
+setup packaging script for MozillaHg
+"""
+
+import os
+
+version = "0.0"
+dependencies = ['MakeItSo', 'webob']
+
+# allow use of setuptools/distribute or distutils
+kw = {}
+try:
+    from setuptools import setup
+    kw['entry_points'] = """
+      [console_scripts]
+      MozillaHg = MozillaHg.main:main
+      MozillaHg-template = MozillaHg.template:main
+"""
+    kw['install_requires'] = dependencies
+except ImportError:
+    from distutils.core import setup
+    kw['requires'] = dependencies
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = ''
+
+
+setup(name='MozillaHg',
+      version=version,
+      description="mozilla interface to mercurial",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/mozilla/hg/MozillaHg',
+      license='',
+      packages=['mozillahg'],
+      include_package_data=True,
+      zip_safe=False,
+      **kw
+      )
+