diff setup.py @ 0:df6a8049e9a4

initial port from http://k0s.org/mozilla/try.py
author Jeff Hammel <jhammel@mozilla.com>
date Fri, 30 Nov 2012 15:51:06 -0800
parents
children 416f4562005c
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Fri Nov 30 15:51:06 2012 -0800
@@ -0,0 +1,35 @@
+import os
+from setuptools import setup
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = None
+
+version = '0.0'
+
+deps = []
+
+setup(name='mozillatry',
+      version=version,
+      description="push patches to mozilla try server",
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='mozilla',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/mozilla',
+      license='',
+      py_modules=['mozillatry'],
+      packages=[],
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=deps,
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      mozillatry = mozillatry:main
+      """,
+      )
+