diff setup.py @ 0:642e1f903bd0

initial commit of talos, mozutils port of http://k0s.org/mozilla/talos/new-talos-zip-bug.py
author Jeff Hammel <jhammel@mozilla.com>
date Tue, 22 Jan 2013 12:10:40 -0800
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Tue Jan 22 12:10:40 2013 -0800
@@ -0,0 +1,36 @@
+import os
+from setuptools import setup
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = None
+
+version = '0.0'
+
+deps = ['bzconsole',
+        'talostry']
+
+setup(name='releasetalos',
+      version=version,
+      description="create a bug to deploy a new talos.zip",
+      long_description=description,
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='mozilla',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='http://k0s.org/mozilla/hg/ReleaseTalos',
+      license='',
+      py_modules=['releasetalos'],
+      packages=[],
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=deps,
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      releasetalos = releasetalos:main
+      """,
+      )
+