diff setup.py @ 0:b0665b243ccd

initial import of licenser
author Jeff Hammel <jhammel@mozilla.com>
date Mon, 10 May 2010 09:18:26 -0700
parents
children f7d485cedc80
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Mon May 10 09:18:26 2010 -0700
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+version = '0.0'
+
+setup(name='licenser',
+      version=version,
+      description='adds licenses to python packages',
+      long_description="""\
+""",
+      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      keywords='license',
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='',
+      license='MPL',
+      packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=[
+          # -*- Extra requirements: -*-
+      ],
+      entry_points="""
+      # -*- Entry points: -*-
+      [console_scripts]
+      licenser = licenser.main:main
+
+      [licenser.license]
+      MPL = licenser.licenses:MPL
+      """,
+      )