diff setup.py @ 0:3e1f069ac608

stub
author Jeff Hammel <jhammel@mozilla.com>
date Fri, 06 Jul 2012 16:22:42 -0700
parents
children a10ae1ea8325
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Fri Jul 06 16:22:42 2012 -0700
@@ -0,0 +1,45 @@
+"""
+setup packaging script for talosnames
+"""
+
+import os
+
+version = "0.0"
+dependencies = ['MakeItSo', 'webob']
+
+# allow use of setuptools/distribute or distutils
+kw = {}
+try:
+    from setuptools import setup
+    kw['entry_points'] = """
+      [console_scripts]
+      talosnames = talosnames.main:main
+      talosnames-template = talosnames.template:main
+"""
+    kw['install_requires'] = dependencies
+except ImportError:
+    from distutils.core import setup
+    kw['requires'] = dependencies
+
+try:
+    here = os.path.dirname(os.path.abspath(__file__))
+    description = file(os.path.join(here, 'README.txt')).read()
+except IOError:
+    description = ''
+
+
+setup(name='talosnames',
+      version=version,
+      description="correlate names of talos",
+      long_description=description,
+      classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+      author='Jeff Hammel',
+      author_email='jhammel@mozilla.com',
+      url='',
+      license='',
+      packages=['talosnames'],
+      include_package_data=True,
+      zip_safe=False,
+      **kw
+      )
+