diff setup.py @ 5:6c6766109dac

adding README.txt and use it in setup.py long_description
author k0s <k0scist@gmail.com>
date Wed, 24 Feb 2010 20:21:47 -0500
parents ce757057961c
children 59245309f054
line wrap: on
line diff
--- a/setup.py	Wed Feb 24 20:11:25 2010 -0500
+++ b/setup.py	Wed Feb 24 20:21:47 2010 -0500
@@ -1,13 +1,18 @@
 from setuptools import setup, find_packages
 import sys, os
 
+# read the description from the file
+try:
+    description = file(os.path.join(os.path.dirname(__file__), 'README.txt')).read()
+except:
+    description = '' 
+
 version = "0.2"
 
 setup(name='CAPTCHAmiddleware',
       version=version,
       description="put CAPTCHAs on forms",
-      long_description="""
-""",
+      long_description=description,
       classifiers=[], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
       author='Jeff Hammel',
       author_email='k0scist@gmail.com',